设为首页收藏本站订阅更新

无忧脚本

 找回密码
 加入无忧

QQ登录

只需一步,快速开始

搜索
查看: 1568|回复: 0

[求助] 请教高手一个ie兼容的问题!

[复制链接]
发表于 2013-12-15 20:19:04 | 显示全部楼层 |阅读模式
我们的网站在ie8下面都正常。

可是客户用的ie10   , ie11,网页出现错位,用户需要点击浏览器上的“兼容性视图”才能正常浏览。用户要求我们解决不点击也能强制兼容的问题。

于是我们在网页里增加了“<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10" /> ”

居然没任何变化。

于是查到网友网上说在apache做如下设置可以强制兼容模式
Apache:
在httpd.conf中加载headers_module模块,并加入
<IfModule headers_module>
       Header set X-UA-Compatible "IE=EmulateIE7"
</IfModule>
保存,重启apche。

使用IE8访问网站自动使用兼容模式。


我的问题是:我的系统是apache tomcat 6,并无httpd.conf文件,请问我该修改哪个配置文件,让用户的浏览器始终都是强制兼容模式?如何改配置文件?
您需要登录后才可以回帖 登录 | 加入无忧

本版积分规则

小黑屋|手机版|Archiver|无忧脚本 ( 苏ICP备05080427号 )|值班电话:027-62300445   鄂公网安备 42011102000433号

GMT+8, 2017-11-20 01:27 , Processed in 0.090550 second(s), 9 queries , Gzip On, Memcache On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表